CentOS 7安装TeamViewer

1、wget https://download.teamviewer.com/download/linux/teamviewer.x86_64.rpm

2、yum localinstall teamviewer.x86_64.rpm

出现一个error提示,关键词:libQt5WebKitWidgets.so,以下是错误原文

Error: Package: teamviewer-13.1.8286-0.x86_64 (/teamviewer.x86_64)
           Requires: libQt5WebKitWidgets.so.5()(64bit) >= 5.5
Error: Package: teamviewer-13.1.8286-0.x86_64 (/teamviewer.x86_64)
           Requires: libQt5WebKit.so.5()(64bit) >= 5.5
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

3、 wget http://dl.fedoraproject.org/pub/epel/7/x86_64/Packages/q/qt5-qtwebkit-5.9.1-1.el7.x86_64.rpm

4、yum localinstall qt5-qtwebkit-5.9.1-1.el7.x86_64.rpm

Installing:
 qt5-qtwebkit                             x86_64                      5.9.1-1.el7                            /qt5-qtwebkit-5.9.1-1.el7.x86_64                       38 M
Installing for dependencies:
 pcre2-utf16                              x86_64                      10.23-2.el7                            base                                                  189 k
 qt5-qtbase                               x86_64                      5.9.2-3.el7                            base                                                  3.3 M
 qt5-qtbase-common                        noarch                      5.9.2-3.el7                            base                                                   26 k
 qt5-qtbase-gui                           x86_64                      5.9.2-3.el7                            base                                                  5.2 M
 qt5-qtdeclarative                        x86_64                      5.9.2-1.el7                            base                                                  3.2 M
 qt5-qtlocation                           x86_64                      5.9.2-1.el7                            base                                                  919 k
 qt5-qtsensors                            x86_64                      5.9.2-1.el7                            base                                                  208 k
 qt5-qtwebchannel                         x86_64                      5.9.2-1.el7                            base                                                   78 k
 qt5-qtxmlpatterns                        x86_64                      5.9.2-1.el7                            base                                                  1.1 M
 xcb-util-image                           x86_64                      0.4.0-2.el7                            base                                                   15 k
 xcb-util-keysyms                         x86_64                      0.4.0-1.el7                            base                                                   10 k
 xcb-util-renderutil                      x86_64                      0.3.9-3.el7                            base                                                   12 k
 xcb-util-wm                              x86_64                      0.4.1-5.el7                            base                                                   25 k
Updating for dependencies:
 dbus                                     x86_64                      1:1.10.24-7.el7                        base                                                  245 k
 dbus-libs                                x86_64                      1:1.10.24-7.el7                        base                                                  169 k
 dbus-x11                                 x86_64                      1:1.10.24-7.el7                        base  

5、yum localinstall teamviewer.x86_64.rpm

Installing:
 teamviewer                                    x86_64                           13.1.8286-0                           /teamviewer.x86_64                            60 M
Installing for dependencies:
 qt5-qtquickcontrols                           x86_64                           5.9.2-1.el7                           base                                         1.1 M
 qt5-qtx11extras                               x86_64                           5.9.2-1.el7                           base 

6、如果x86_64 安装之后打不开GUI 界面,建议安装32位的

wget https://download.teamviewer.com/download/teamviewer.i686.rpm
yum localinstall teamviewer.i686.rpm -y

发表评论

电子邮件地址不会被公开。 必填项已用*标注